NO My Docs Online “Heartbleed” OpenSSL Vulnerability

The recent internet security vulnerability known as “Heartbleed” did not, and does not, involve My Docs Online. ┬áMany secure sites on the internet are recommending users change their passwords, even after those sites have ‘patched’ the vulnerability.

There is no need to do that at My Docs Online. We don’t use, and never have used, the versions of OpenSSL involved.

Haven’t heard of Heartbleed? Other sites you use may be compromised. You can learn more here.

Leave a Comment

Previous post:

Next post: